OPENCRYPTO(9) BSD Kernel Developer's Manual OPENCRYPTO(9)NAME
opencrypto, crypto_get_driverid, crypto_register, crypto_kregister,
crypto_unregister, crypto_done, crypto_kdone, crypto_newsession,
crypto_freesession, crypto_dispatch, crypto_kdispatch, crypto_getreq,
crypto_freereq — API for cryptographic services in the kernel
SYNOPSIS
#include <opencrypto/cryptodev.h>
int32_t
crypto_get_driverid(u_int32_t);
int
crypto_register(u_int32_t, int, u_int16_t, u_int32_t,
int (*)(void *, u_int32_t *, struct cryptoini *),
int (*)(void *, u_int32_t *), int (*)(u_int64_t),
int (*)(struct cryptop *), void *);
int
crypto_kregister(u_int32_t, int, u_int32_t,
int (*)(void *, struct cryptkop *, int), void *);
int
crypto_unregister(u_int32_t, int);
void
crypto_done(struct cryptop *);
void
crypto_kdone(struct cryptkop *);
int
crypto_newsession(u_int64_t *, struct cryptoini *, int);
int
crypto_freesession(u_int64_t);
int
crypto_dispatch(struct cryptop *);
int
crypto_kdispatch(struct cryptkop *);
struct cryptop *
crypto_getreq(int);
void
crypto_freereq(struct cryptop *);
#define EALG_MAX_BLOCK_LEN 16
struct cryptoini {
int cri_alg;
int cri_klen;
int cri_rnd;
void *cri_key;
u_int8_t cri_iv[EALG_MAX_BLOCK_LEN];
struct cryptoini *cri_next;
};
struct cryptodesc {
int crd_skip;
int crd_len;
int crd_inject;
int crd_flags;
struct cryptoini CRD_INI;
struct cryptodesc *crd_next;
};
struct cryptop {
TAILQ_ENTRY(cryptop) crp_next;
u_int64_t crp_sid;
int crp_ilen;
int crp_olen;
int crp_etype;
int crp_flags;
void *crp_buf;
void *crp_opaque;
struct cryptodesc *crp_desc;
int (*crp_callback)(struct cryptop *);
void *crp_mac;
};
struct crparam {
void *crp_p;
u_int crp_nbits;
};
#define CRK_MAXPARAM 8
struct cryptkop {
TAILQ_ENTRY(cryptkop) krp_next;
u_int krp_op; /* i.e. CRK_MOD_EXP or other */
u_int krp_status; /* return status */
u_short krp_iparams; /* # of input parameters */
u_short krp_oparams; /* # of output parameters */
u_int32_t krp_hid;
struct crparam krp_param[CRK_MAXPARAM]; /* kvm */
int (*krp_callback)(struct cryptkop *);
};
DESCRIPTION
opencrypto is a framework for drivers of cryptographic hardware to regis‐
ter with the kernel so “consumers” (other kernel subsystems, and eventu‐
ally users through an appropriate device) are able to make use of it.
Drivers register with the framework the algorithms they support, and pro‐
vide entry points (functions) the framework may call to establish, use,
and tear down sessions. Sessions are used to cache cryptographic infor‐
mation in a particular driver (or associated hardware), so initialization
is not needed with every request. Consumers of cryptographic services
pass a set of descriptors that instruct the framework (and the drivers
registered with it) of the operations that should be applied on the data
(more than one cryptographic operation can be requested).
Keying operations are supported as well. Unlike the symmetric operators
described above, these sessionless commands perform mathematical opera‐
tions using input and output parameters.
Since the consumers may not be associated with a process, drivers may not
use condition variables: condvar(9). The same holds for the framework.
Thus, a callback mechanism is used to notify a consumer that a request
has been completed (the callback is specified by the consumer on an per-
request basis). The callback is invoked by the framework whether the
request was successfully completed or not. An error indication is pro‐
vided in the latter case. A specific error code, EAGAIN, is used to
indicate that a session number has changed and that the request may be
re-submitted immediately with the new session number. Errors are only
returned to the invoking function if not enough information to call the
callback is available (meaning, there was a fatal error in verifying the
arguments). No callback mechanism is used for session initialization and
teardown.
The crypto_newsession() routine is called by consumers of cryptographic
services (such as the ipsec(4) stack) that wish to establish a new ses‐
sion with the framework. On success, the first argument will contain the
Session Identifier (SID). The second argument contains all the necessary
information for the driver to establish the session. The third argument
indicates whether a hardware driver should be used (1) or not (0). The
various fields in the cryptoini structure are:
cri_alg Contains an algorithm identifier. Currently supported
algorithms are:
CRYPTO_DES_CBC
CRYPTO_3DES_CBC
CRYPTO_BLF_CBC
CRYPTO_CAST_CBC
CRYPTO_CAMELLIA_CBC
CRYPTO_SKIPJACK_CBC
CRYPTO_ARC4
CRYPTO_AES_CBC
CRYPTO_AES_CTR
CRYPTO_AES_GCM_16
CRYPTO_AES_GMAC
CRYPTO_AES_128_GMAC
CRYPTO_AES_192_GMAC
CRYPTO_AES_256_GMAC
CRYPTO_AES_XCBC_MAC_96
CRYPTO_MD5
CRYPTO_MD5_HMAC
CRYPTO_MD5_HMAC_96
CRYPTO_MD5_KPDK
CRYPTO_NULL_CBC
CRYPTO_NULL_HMAC
CRYPTO_SHA1
CRYPTO_SHA1_HMAC
CRYPTO_SHA1_HMAC_96
CRYPTO_SHA1_KPDK
CRYPTO_SHA2_256_HMAC
CRYPTO_SHA2_384_HMAC
CRYPTO_SHA2_512_HMAC
CRYPTO_RIPEMD160_HMAC
CRYPTO_RIPEMD160_HMAC_96
CRYPTO_DEFLATE_COMP
CRYPTO_DEFLATE_COMP_NOGROW
CRYPTO_GZIP_COMP
cri_klen Specifies the length of the key in bits, for variable-size
key algorithms.
cri_rnd Specifies the number of rounds to be used with the algo‐
rithm, for variable-round algorithms.
cri_key Contains the key to be used with the algorithm.
cri_iv Contains an explicit initialization vector (IV), if it does
not prefix the data. This field is ignored during initial‐
ization. If no IV is explicitly passed (see below on
details), a random IV is used by the device driver process‐
ing the request.
cri_next Contains a pointer to another cryptoini structure. Multi‐
ple such structures may be linked to establish multi-algo‐
rithm sessions (ipsec(4) is an example consumer of such a
feature).
The cryptoini structure and its contents will not be modified by the
framework (or the drivers used). Subsequent requests for processing that
use the SID returned will avoid the cost of re-initializing the hardware
(in essence, SID acts as an index in the session cache of the driver).
crypto_freesession() is called with the SID returned by
crypto_newsession() to disestablish the session.
crypto_dispatch() is called to process a request. The various fields in
the cryptop structure are:
crp_sid Contains the SID.
crp_ilen Indicates the total length in bytes of the buffer to be
processed.
crp_olen On return, contains the length of the result, not including
crd_skip. For symmetric crypto operations, this will be
the same as the input length.
crp_alloctype
Indicates the type of buffer, as used in the kernel
malloc(9) routine. This will be used if the framework
needs to allocate a new buffer for the result (or for re-
formatting the input).
crp_callback This routine is invoked upon completion of the request,
whether successful or not. It is invoked through the
crypto_done() routine. If the request was not successful,
an error code is set in the crp_etype field. It is the
responsibility of the callback routine to set the appropri‐
ate spl(9) level.
crp_etype Contains the error type, if any errors were encountered, or
zero if the request was successfully processed. If the
EAGAIN error code is returned, the SID has changed (and has
been recorded in the crp_sid field). The consumer should
record the new SID and use it in all subsequent requests.
In this case, the request may be re-submitted immediately.
This mechanism is used by the framework to perform session
migration (move a session from one driver to another,
because of availability, performance, or other considera‐
tions).
Note that this field only makes sense when examined by the
callback routine specified in crp_callback. Errors are
returned to the invoker of crypto_process() only when
enough information is not present to call the callback rou‐
tine (i.e., if the pointer passed is NULL or if no callback
routine was specified).
crp_flags Is a bitmask of flags associated with this request. Cur‐
rently defined flags are:
CRYPTO_F_IMBUF The buffer pointed to by crp_buf is an mbuf
chain.
crp_buf Points to the input buffer. On return (when the callback
is invoked), it contains the result of the request. The
input buffer may be an mbuf chain or a contiguous buffer
(of a type identified by crp_alloctype), depending on
crp_flags.
crp_opaque This is passed through the crypto framework untouched and
is intended for the invoking application's use.
crp_desc This is a linked list of descriptors. Each descriptor pro‐
vides information about what type of cryptographic opera‐
tion should be done on the input buffer. The various
fields are:
crd_skip The offset in the input buffer where processing
should start.
crd_len How many bytes, after crd_skip, should be pro‐
cessed.
crd_inject Offset from the beginning of the buffer to
insert any results. For encryption algorithms,
this is where the initialization vector (IV)
will be inserted when encrypting or where it
can be found when decrypting (subject to
crd_flags). For MAC algorithms, this is where
the result of the keyed hash will be inserted.
crd_flags For adjusting general operation from userland,
the following flags are defined:
CRD_F_ENCRYPT For encryption algorithms,
this bit is set when encryp‐
tion is required (when not
set, decryption is per‐
formed).
CRD_F_IV_PRESENT For encryption algorithms,
this bit is set when the IV
already precedes the data,
so the crd_inject value will
be ignored and no IV will be
written in the buffer. Oth‐
erwise, the IV used to
encrypt the packet will be
written at the location
pointed to by crd_inject.
Some applications that do
special “IV cooking”, such
as the half-IV mode in
ipsec(4), can use this flag
to indicate that the IV
should not be written on the
packet. This flag is typi‐
cally used in conjunction
with the CRD_F_IV_EXPLICIT
flag.
CRD_F_IV_EXPLICIT For encryption algorithms,
this bit is set when the IV
is explicitly provided by
the consumer in the crd_iv
fields. Otherwise, for
encryption operations the IV
is provided for by the
driver used to perform the
operation, whereas for
decryption operations it is
pointed to by the crd_inject
field. This flag is typi‐
cally used when the IV is
calculated “on the fly” by
the consumer, and does not
precede the data (some
ipsec(4) configurations, and
the encrypted swap are two
such examples).
CRD_F_COMP For compression algorithms,
this bit is set when com‐
pression is required (when
not set, decompression is
performed).
CRD_INI This cryptoini structure will not be modified
by the framework or the device drivers. Since
this information accompanies every crypto‐
graphic operation request, drivers may re-ini‐
tialize state on-demand (typically an expensive
operation). Furthermore, the cryptographic
framework may re-route requests as a result of
full queues or hardware failure, as described
above.
crd_next Point to the next descriptor. Linked opera‐
tions are useful in protocols such as ipsec(4),
where multiple cryptographic transforms may be
applied on the same block of data.
crypto_getreq() allocates a cryptop structure with a linked list of as
many cryptodesc structures as were specified in the argument passed to
it.
crypto_freereq() deallocates a structure cryptop and any cryptodesc
structures linked to it. Note that it is the responsibility of the call‐
back routine to do the necessary cleanups associated with the opaque
field in the cryptop structure.
crypto_kdispatch() is called to perform a keying operation. The various
fields in the crytokop structure are:
krp_op Operation code, such as CRK_MOD_EXP.
krp_status Return code. This errno-style variable indicates whether
there were lower level reasons for operation failure.
krp_iparams Number of input parameters to the specified operation.
Note that each operation has a (typically hardwired) num‐
ber of such parameters.
krp_oparams Number of output parameters from the specified operation.
Note that each operation has a (typically hardwired) num‐
ber of such parameters.
krp_kvp An array of kernel memory blocks containing the parame‐
ters.
krp_hid Identifier specifying which low-level driver is being
used.
krp_callback Callback called on completion of a keying operation.
The following sysctl entries exist to adjust the behaviour of the system
from userland:
kern.usercrypto Allow (1) or forbid (0) userland access to
/dev/crypto.
kern.userasymcrypto Allow (1) or forbid (0) userland access to do
asymmetric crypto requests.
kern.cryptodevallowsoft Enable/disable access to hardware versus soft‐
ware operations:
< 0 Force userlevel requests to use software
operations, always.
= 0 Use hardware if present, grant userlevel
requests for non-accelerated operations
(handling the latter in software).
> 0 Allow user requests only for operations
which are hardware-accelerated.
DRIVER-SIDE API
The crypto_get_driverid(), crypto_register(), crypto_kregister(),
crypto_unregister(), and crypto_done() routines are used by drivers that
provide support for cryptographic primitives to register and unregister
with the kernel crypto services framework. Drivers must first use the
crypto_get_driverid() function to acquire a driver identifier, specifying
the flags as an argument (normally 0, but software-only drivers should
specify CRYPTOCAP_F_SOFTWARE). For each algorithm the driver supports,
it must then call crypto_register(). The first argument is the driver
identifier. The second argument is an array of CRYPTO_ALGORITHM_MAX + 1
elements, indicating which algorithms are supported. The last three
arguments are pointers to three driver-provided functions that the frame‐
work may call to establish new cryptographic context with the driver,
free already established context, and ask for a request to be processed
(encrypt, decrypt, etc.) crypto_unregister() is called by drivers that
wish to withdraw support for an algorithm. The two arguments are the
driver and algorithm identifiers, respectively. Typically, drivers for
pcmcia(4) crypto cards that are being ejected will invoke this routine
for all algorithms supported by the card. If called with
CRYPTO_ALGORITHM_ALL, all algorithms registered for a driver will be
unregistered in one go and the driver will be disabled (no new sessions
will be allocated on that driver, and any existing sessions will be
migrated to other drivers). The same will be done if all algorithms
associated with a driver are unregistered one by one.
The calling convention for the three driver-supplied routines is:
int (*newsession) (void *, u_int32_t *, struct cryptoini *);
int (*freesession) (void *, u_int64_t);
int (*process) (void *, struct cryptop *, int);
On invocation, the first argument to newsession() contains the driver
identifier obtained via crypto_get_driverid(). On successfully return‐
ing, it should contain a driver-specific session identifier. The second
argument is identical to that of crypto_newsession().
The freesession() routine takes as argument the SID (which is the con‐
catenation of the driver identifier and the driver-specific session iden‐
tifier). It should clear any context associated with the session (clear
hardware registers, memory, etc.).
The process() routine is invoked with a request to perform crypto pro‐
cessing. This routine must not block, but should queue the request and
return immediately. Upon processing the request, the callback routine
should be invoked. In case of error, the error indication must be placed
in the crp_etype field of the cryptop structure. The hint argument can
be set to CRYPTO_HINT_MORE when there will be more request right after
this request. When the request is completed, or an error is detected,
the process() routine should invoke crypto_done(). Session migration may
be performed, as mentioned previously.
The kprocess() routine is invoked with a request to perform crypto key
processing. This routine must not block, but should queue the request
and return immediately. Upon processing the request, the callback rou‐
tine should be invoked. In case of error, the error indication must be
placed in the krp_status field of the cryptkop structure. When the
request is completed, or an error is detected, the kprocess() routine
should invoke crypto_kdone().
RETURN VALUEScrypto_register(), crypto_kregister(), crypto_unregister(),
crypto_newsession(), and crypto_freesession() return 0 on success, or an
error code on failure. crypto_get_driverid() returns a non-negative
value on error, and -1 on failure. crypto_getreq() returns a pointer to
a cryptop structure and NULL on failure. crypto_dispatch() returns
EINVAL if its argument or the callback function was NULL, and 0 other‐
wise. The callback is provided with an error code in case of failure, in
the crp_etype field.
FILES
sys/opencrypto/crypto.c most of the framework code
sys/crypto crypto algorithm implementations
SEE ALSOipsec(4), pcmcia(4), condvar(9), malloc(9)
Angelos D. Keromytis, Jason L. Wright, and Theo de Raadt, The Design of
the OpenBSD Cryptographic Framework, Usenix, 2003, June 2003.
HISTORY
The cryptographic framework first appeared in OpenBSD 2.7 and was written
by Angelos D. Keromytis ⟨angelos@openbsd.org⟩.
Sam Leffler ported the crypto framework to FreeBSD and made performance
improvements.
Jonathan Stone ⟨jonathan@NetBSD.org⟩ ported the cryptoframe from FreeBSD
to NetBSD. opencrypto first appeared in NetBSD 2.0.
BUGS
The framework currently assumes that all the algorithms in a
crypto_newsession() operation must be available by the same driver. If
that's not the case, session initialization will fail.
The framework also needs a mechanism for determining which driver is best
for a specific set of algorithms associated with a session. Some type of
benchmarking is in order here.
Multiple instances of the same algorithm in the same session are not sup‐
ported. Note that 3DES is considered one algorithm (and not three
instances of DES). Thus, 3DES and DES could be mixed in the same
request.
A queue for completed operations should be implemented and processed at
some software spl(9) level, to avoid overall system latency issues, and
potential kernel stack exhaustion while processing a callback.
When SMP time comes, we will support use of a second processor (or more)
as a crypto device (this is actually AMP, but we need the same basic sup‐
port).
BSD September 17, 2011 BSD